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I. QUICK CHECKLIST FOR TROUBLESHOOTING 
CPAS-3000 PROBLEMS 

THE CUSTOMER NEEDS TO ANSWER “YES” TO THE 
FOLLOWING QUESTIONS: 

□ Is the aircraft on the ground?
□ Is the Maintenance or Data Load Enable switch(es) on?
□ Is the XM GWX circuit breaker pulled? (Labeled

DATALINK in Cessna aircraft)
□ Is the laptop plugged in to an external power source?
□ Is the correct cable type being used? (straight vs.

crossover) note: Cessna uses straight in all
applications. Has the cable ever worked before?

□ Is the cable plugged into the correct aircraft and
computer ports?

□ Has the laptop power saving features been
deactivated?

□ Any wireless adapters installed? Are they disabled?
□ Are the network adapter power saving features

disabled?
□ Virus scanning software disabled or removed?
□ Firewall software disabled or removed?
□ Any virtual private network software installed? Is it

disabled?
□ Has your CPAS-3000 ever worked before?
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II. DETAILED TROUBLESHOOTING OF CPAS-3000
PROBLEMS BY SYMPTOM. 

Note: AFTER EACH DEBUG STEP, A LOAD MAY BE ATTEMPTED TO SEE 
IF THE PROBLEM WAS FIXED. 

After clicking “refresh targets”, no targets are available 
in the "Select Target/LRU to be Updated" window 

POSSIBLE 
CAUSES: 

Incorrect network adapter configuration, wrong network adapter being used, wireless 
network adapter selected when CPAS-3000 was installed, VPN enabled, or firewall 
enabled. Note: Before going through this list, ask the user if they have tried re-clicking 
“refresh targets”.  Sometimes the list does not populate on the first target refresh. 

DEBUG STEP 1 Verify VPN, virus software, and firewall software are disabled 
PROCEDURE Varies by program 

DEBUG STEP 2 Check network adapter communications to FSU and verify proper network adapter 
configurations   

PROCEDURE 1. CPAS-3000 Data Loader must be running and connected to aircraft, if not double
click the CPAS-3000 Launch Pad icon. Double click the Dataload icon, a message
window “Waiting For The Network Adapter To Be Configured…” will appear for a
few seconds

2. On the Windows taskbar , click the “Start” button , click “Run”.
3. Type cmd into the dialog window, then click the “OK”.
4. In the resulting command window, type ipconfig and press the “Enter” key.
5. In the command window, you should see at least one Ethernet adapter local area

connection with an IP Address number.  If "Media State:... Media Disconnected"
is shown, you should also see no active link light next to the cable port on the PC.
Suspect one or both of the following:

a. Wireless network adapter was selected when CPAS-3000 was
installed.  If a wireless adapter was selected upon installation, CPAS-
3000 will need to be uninstalled and reinstalled with the correct
network adapter.

b. Network cable plugged into wrong computer port. (Note: this problem
usually causes a failure window that reads “Unable To Refresh Targets. An
Error Occurred During The SNIP Request. Windows error code 10049…”

If "Media Disconnected" is not shown you should see at least one Ethernet 
adapter local area connection with an IP Address of 10.191.254.254 and a 
Subnet Mask of 255.240.0.0. 

If another IP Address or Subnet Mask is shown, the network adapter was 
configured incorrectly when CPAS-3000 Dataloader was launched (refer to 
DEBUG STEP 3) 

6. In the resulting command line window, type ping 10.177.28.1 (left FSU) or ping
10.178.28.1 (right FSU) and press the “Enter” key.

7. The proper response should be reply from 10.177.28.1 … (or reply from
10.178.28.1 …).  If you get this response, the FSU is operational, try refreshing
targets again.  If still no targets, recheck to make sure any VPN is disabled and
virus protection software is off.

8. If “Destination host is unreachable” is shown and the link light is on, the
network adapter was configured incorrectly when CPAS-3000 Data Loader was
launched (refer to DEBUG STEP 3).

Continued on next page… 



Created on 2/16/2006 11:33:00 AM 

© Copyright 2018 Rockwell Collins Page 4 of 11 

DEBUG STEP 3  Ensure proper network adapter configuration when CPAS-3000 Data Loader is running.  

PROCEDURE 
1. In the CPAS-3000  data loader window select the “View” dropdown menu, and

then select “Configuration…”.
2. Click on the “Advanced…” button, click the “OK” button in the caution window.
3. Select the “Network” tab.
4. Click the "Restore Network Defaults" button.
5. Click the “Yes” button when prompted “Are you sure..”.
6. Click the “OK” button.
7. Click the “Yes” button when prompted “Do you want to save these settings

permanently…”.
8. Click the “OK” button to close the Data Loader configuration window.
9. Exit and restart CPAS-3000

After clicking "Refresh Targets", button never returns to 
original state after two minutes, or button stays "grayed 

out". 
POSSIBLE 

CAUSES: 
The network adapter has not completed it's reconfiguration process when CPAS-3000 
initializes  

DEBUG STEP 1 Verify “Auto-Refresh On Startup” feature is not selected 

PROCEDURE 1. In the CPAS-3000 dataloader window, select the “View” dropdown menu, and
then select “Configuration…”

2. Uncheck the "Automatically Refresh Targets on Startup" box; Click the “OK”
button.

3. Click the “Yes” button when prompted “Do you want to save these settings
permanently…”

4. Exit and restart CPAS-3000
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After clicking "Refresh Targets" an error window appears 
that reads "Unable To Refresh Targets. An Error 

Occurred During The SNIP Request. Windows error code 
10049…". 

POSSIBLE 
CAUSES: 

Network cable not hooked up, wrong type of cable, faulty cable, faulty wiring from FSU to 
aircraft data load RJ45 port, wireless adapter selected when CPAS-3000 was installed. 

DEBUG STEP 1 Verify correct network cable is plugged into correct aircraft and computer ports 

PROCEDURE See aircraft manual for RJ45 port location and markings. See PC manual (or network 
card manual) for network adapter ports.  

DEBUG STEP 2 Verify cable is good 

PROCEDURE Verify network cable has continuity or substitute with a known good cable. 

DEBUG STEP 3 Verify network cable is of the correct type (crossover or straight). 

PROCEDURE Refer to Aircraft manual for cable type 

DEBUG STEP 4 Verify wireless adapter was not selected when CPAS was installed (if not installed, skip 
this step). 

PROCEDURE 1. In the CPAS-3000 Data Loader window select the “View” dropdown menu,
and then select “Configuration…”.

2. Click on the “Advanced…” button, click the “OK” button in the caution
window.

3. Select the “Network” tab.
4. Verify that network adapter displayed as the “Selected network adapter” is

not a wireless network adapter.  Note: If a wireless adapter was selected
upon installation, CPAS-3000 will need to be uninstalled and reinstalled
with the correct network adapter.  NOTE: “Restore Network Defaults does
NOT CHANGE THE NETWORK ADAPTER.
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After clicking “Refresh Targets”, the only target listed is 
NODE in the "Select Target/LRU to be Updated" window 

POSSIBLE 
CAUSES: 

FSU still warming up or in a transition state when "Refresh Targets" was selected. 

DEBUG STEP 1 Recycle FSU power 

PROCEDURE 1. Cycle FSU circuit breaker, wait 2-3 minutes
2. Access MFD “DATABASE EFFECTIVITY” page and verify page data populates

the display.
3. Select “Refresh Targets” again.

After clicking “Refresh Targets”, the only targets listed 
are “FSU and NODE” in the "Select Target/LRU to be 

Updated" window. 
POSSIBLE 

CAUSES: 
FSU has not entered data load mode, incorrect data loader configuration settings, or 
incorrect network adapter configuration.  

Note: The flight deck effects of the FSU entering data load mode are shown on the MFD 
“DATABASE EFFECTIVITY” page.  The message “PROCESSING REQUEST” is 
annunciated for a few moments followed by the messages “DATABASE EFFECTIVITY 
FAULT” and “FSU INOP” 

DEBUG STEP 1 Verify aircraft “data load enable” or "maintenance" switch is on.   

PROCEDURE Refer to aircraft manual 

DEBUG STEP 2 Verify CPAS is initiating data load mode automatically on FSU and the network adapter 
is correctly configured 

PROCEDURE 1. Select the “View” dropdown menu, and then select “Configuration…”
2. Verify the "Automatically Initiate Data Load Mode on FSU” box is checked
3. Click the “Advanced” button; click the “OK” button when prompted with a Caution

window.
4. Click the “FSU” tab and click “Restore FSU Defaults” button, click the “YES”

button when prompted with “Are you sure you want to…”.
5. Select the “Network” tab.
6. Click the "Restore Network Defaults" button.
7. Click the “Yes” button when prompted “Are you sure..”.
8. Close the Configuration window by clicking the “OK” button.
9. Click the “Yes” button when prompted “Do you want to save these settings

permanently…”.
10. Close the “Data Loader Configuration Window” by clicking the “OK” button.

STEP 3 Verify FSU data load enable discrete pins are properly configured 

PROCEDURE Check for ground signal at connector J1, pins 1, 2, 96, 116 
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After clicking “Refresh Targets” only targets listed are 
“FSU”, “NODE”, and “429-Based LRU” but no FMC or 

MDC. 
POSSIBLE 

CAUSES: 
FMC or MDC failure, FMC or MDC not powered, FMC or MDC not operational, or FSU 
internal failure 

NOTE: Loss of MDC or FMC may be due to dropping voltage levels; this is common with 
situations where the avionics power source is a battery.  The optimum situation is to 
have a constant power source such as an external power “cart”, auxiliary power unit, or 
the engine’s generators.  

STEP 1 Verify target LRU circuit breaker is on. 

PROCEDURE Refer to aircraft manual 

STEP 2 Verify FMC, or MDC, is operational. 

PROCEDURE 1. Look for CDU FMS operation, or look for MFD MDC operation.

STEP 3 Verify FMC or MDC is responsive to CPAS-3000  

PROCEDURE 1. Select the “View” dropdown menu, and then select “Configuration…”
2. Click the “Advanced” button; click the “OK” button when prompted with a Caution

window.
3. Select the “FSU” tab.
4. Verify a solid green circle next to the target LRU in the “Port Connected” column,

if red “X” is shown, FSU has an internal error (try cycling FSU power and
restarting CPAS-3000; verify still not there).

5. Verify a solid green circle next to the target LRU in the “LRU Responding”
column, if red “X” is shown suspect LRU power input or LRU to FSU wiring.
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Upload process aborts. 
POSSIBLE 

CAUSES: 
Corrupted database files, missing database files, network adapter driver has a problem, 
or incorrect network adapter configuration  

DEBUG STEP 1 Verify wireless adapter is disabled (if not installed, skip this step). Note: Inform customer
that in order to use the wireless adapter when not using CPAS-3000 that they must 
enable it. 

PROCEDURE 1. Click on the Windows start menu button in the lower left hand corner of the
desktop

2. Right click on the “My Computer” icon located on the Windows Start Menu and
select the “Properties” option. (Do not use the desktop shortcut to My Computer)

3. Click the “Hardware” tab in the System Properties window.
4. Click the “Device Manager” button.
5. In the Device Manager window, a list of hardware components installed on the

computer is shown. Open the "Network adapters" item in the list by clicking the
"+" sign located to the left of the icon.

6. Look for a network adapter with the word “wireless” in its name (note: there is no
guarantee that the word wireless will appear for a wireless adapter).

7. Right Click on the Wireless network adapter icon and select “Disable”.
8. Click the “Yes” button when prompted with a window that reads “Disabling this

device will cause it to…”

DEBUG STEP 2  Verify XM Graphical Weather LRU circuit breaker is off. Note: in Cessna aircraft this
breaker is labeled DATALINK. 

PROCEDURE Refer to aircraft manual for circuit breaker(s) location 

DEBUG STEP 3 Load Data/Software from laptop hard drive instead of CD-ROM. 

PROCEDURE Import data/software into the computer hard drive (if not previously done) 

1. From the CPAS-3000 Launch Pad Window double click the “Manage
Data/Software” icon (or you can open this from the CPAS-3000 Data Loader
window by select “Manage Data/Software…” from the “File” dropdown menu
located at the top of the window)

2. In the “Manage Data/Software” window, click the “Import…” button.
3. In the “Drives” dropdown box, select the CD-ROM drive that contains the disk

you want to load.
4. If the desired data/software is shown in the right hand window, click on the check

box just to the left of the data/software. NOTE: If the desired data/software is not
shown it may be in a subdirectory on the disk.  Open the subdirectory in the left
hand window and then check the box next to the desired data/software in the
right hand window

5. Click the “OK” button to start the importation process.  A status box will appear
that will read “Done!” when the importation is complete. Note: some imports take
up to three minutes.

6. Click the “Close” button for both the “Importing Data/Software…” window and the
“Manage Data/Software” window

Continued on next page… 
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DEBUG STEP 4 Verify laptop virus scan software is turned off 

PROCEDURE Varies by program 
DEBUG STEP 5 Verify laptop power saving settings and network card power saving settings are turned 

off 

PROCEDURE 1. Click on the Windows start menu button in the lower left hand corner of the
desktop

2. Right click on the “My Computer” icon located on the Windows Start Menu and
select the “Properties” option. (Do not use the desktop shortcut to My Computer)

3. Click the “Hardware” tab in the System Properties window.
4. Click the “Device Manager” button.
5. In the “Device Manager” window, open the "Network adapters" item in the list by

clicking the "+" sign located to the left of the icon.”
6. Find the network adapter selected when installing CPAS-3000. Right click on the

network adapter and select “Properties”
7. Click the “Power Management” tab Note: Some computers may not have this

tab, if so then skip to procedure step 9 in this debugging step.
8. Uncheck the box next to “Allow the computer to turn off this device to save

power”. Click OK
9. Right click on any empty part of the Windows Desktop, and select “Properties”.
10. Click the “Screen Saver” tab
11. Click the “Power…” button
12. In the “Plugged in” column click on the dropdown menu next to “Turn off hard

disks:” and select “Never”
13. In the “Plugged in” column click on the dropdown menu next to “System

standby:” and select “Never”
14. Click on the “Hibernate” tab
15. Uncheck the box next to “Enable hibernation”

DEBUG STEP 6 Is load process always aborting during start of a load (.LUH file)? If so, verify MTU size is 
set to default of 576. 

PROCEDURE 1. In the CPAS-3000 program, select the “View” dropdown menu, and then select
“Configuration…”

2. Click the “Advanced” button; click the “OK” button when prompted with a Caution
window.

3. Select the “Network” tab.
4. Click the "Restore Network Defaults" button.
5. Click the “Yes” button when prompted, “Are you sure you want to restore the

default values”
6. Click the “Yes” button when prompted, “Do you want to save these settings

permanently for all future data loader sessions”.
DEBUG STEP 7 Is the Data/Software file always aborting at same point? If so, check database integrity 

(only applicable to -003 and greater statuses of CPAS-3000) Note: If the Charts 
database is aborting at 11%, then proceed to DEBUG STEP 9. 

1. In the CPAS-3000 Launch Pad window double click the “Manage Data/Software”
icon.

2. Select the suspect file in the “Data/Software Installed on CPAS:” column.
3. Click the “Check Integrity” button.
4. Verify that “Integrity check succeeded” appears in the “Check Integrity” window,

click the “close” button. If the check fails then suspect that the Data/Software file
is corrupted.  Try a new copy of the data/software.

5. Click the “close” button in the “Manage Data/Software” window.

Continued on next page… 



Created on 2/16/2006 11:33:00 AM 

© Copyright 2018 Rockwell Collins Page 10 of 11 

DEBUG STEP 8 Reduce 615A block size to 512 

PROCEDURE 1. In the CPAS-3000 Data Loader window, select the “View” dropdown menu, and
then select “Configuration…”

2. Click the “Advanced” button; click the “OK” button when prompted with a Caution
window.

3. Select the “615A” tab.
4. In the entry point next to “Block Size (bytes):” type 512
5. Click the “Yes” button when prompted, “Do you want to save these settings

permanently for all future data loader sessions”
DEBUG STEP 9 Update the network adapter driver.  Note: this debug step will most likely require internet

access if an updated driver is not located on the laptop or on laptop OEM provided CD-
ROM.   

PROCEDURE 1. Click on the Windows start menu button in the lower left hand corner of the
desktop

2. Right click on the “My Computer” icon located on the Windows Start Menu and
select the “Properties” option. (Do not use the desktop shortcut to My Computer)

3. Click the “Hardware” tab in the System Properties window.
4. Click the “Device Manager” button.
5. In the “Device Manager” window, open the "Network adapters" item in the list by

clicking the "+" sign located to the left of the icon.”
6. Find the network adapter selected when installing CPAS-3000. Right click on the

network adapter and select “Update Driver…”
7. If you have a Laptop OEM provided CD-ROM, install it in the CD tray.
8. Follow “Hardware Update Wizard” window prompts and recommended

instructions (Note: it may be necessary to search the Internet for an updated
driver)

STEP 7 Send laptop to Collins for continued debugging and study 
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III. GENERAL COMPUTER OPERATIONS QUESTIONS

How do I determine what network adapters are installed on my laptop? 

1. Find the My Computer icon. My Computer is installed either on the Windows desktop or
on the Windows Start Menu.

2. Right-click My Computer and select the Properties option from the pop-up menu that
appears. A new System Properties window will appear on the screen.

3. Click the Hardware tab in the System Properties window.
4. Click the Device Manager button located near the top of this window. A new Device

Manager window will appear on the screen.
5. In the Device Manager window, a list of hardware components installed on the computer

is shown. Open the "Network adapters" item in the list by clicking the "+" sign located to
the left of the icon. The Network adapters section of the window will expand to reveal a
list of all network adapters installed on the computer.

How do I update a network card driver (continuing from above instructions) 

1. Double click on the network card listed.
2. Click the Driver tab and make note of the driver Date and Version.
3. Click the Update Driver Button or visit the network card manufacturer's website using the

driver Date and Version information to find updated network card drivers.

How do I disable network interface card power management features?  

1. Continue from the instructions above by right clicking on the network adapter you
selected when setting up CPAS and select “Properties”

2. Click the “Power Management” tab
3. Uncheck the box next to “allow the computer to turn off this device to save power”
4. Click OK

How do I verify a network adapter is operational  

1. Continue from the instructions for :”How do I determine what network adapters are
installed on my laptop” and right click on the Network adapter you selected when setting
up CPAS and select “properties”

2. Status window should contain the message: “This device is working properly”.

How do I verify a non-wireless network card is not being used for CPAS-
3000 

1. In the CPAS-3000 Data Loader window select the “View” dropdown menu, and then
select “Configuration…”.

2. Click on the “Advanced…” button, click the “OK” button in the caution window.
3. Select the “Network” tab.
4. Verify that network adapter displayed as the “Selected network adapter” is not a wireless

network adapter.  Note: If a wireless adapter was selected upon installation, CPAS-3000
will need to be uninstalled and reinstalled with the correct network adapter.


